aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-20 21:21:28 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-20 21:21:28 +0200
commit8b8dfa7f56b5e85b5f73b7d183c149ea9523d3d8 (patch)
treebc1726b33ebbb021871236be3f1e18229eb88980
parent7ffa5d4a2da7041712c9b6485923f2c3ee455f82 (diff)
downloadguix-8b8dfa7f56b5e85b5f73b7d183c149ea9523d3d8.tar
guix-8b8dfa7f56b5e85b5f73b7d183c149ea9523d3d8.tar.gz
gnu: libgweather: Adjust to new timezone name.
* gnu/packages/gnome.scm (libgweather)[arguments]: In 'pre-check' phase, update "Asia/Rangoon" timezone name.
-rw-r--r--gnu/packages/gnome.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a45f6589ac..f00eeda884 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2598,13 +2598,18 @@ service via the system message bus.")
"/share/zoneinfo"))
#:phases
(modify-phases %standard-phases
- (add-before
- 'check 'pre-check
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "data/check-timezones.sh"
- (("/usr/share/zoneinfo/zone.tab")
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo/zone.tab")))
+ (add-before 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "data/check-timezones.sh"
+ (("/usr/share/zoneinfo/zone.tab")
+ (string-append (assoc-ref inputs "tzdata")
+ "/share/zoneinfo/zone.tab")))
+
+ ;; 'Asia/Rangoon' was renamed in tzdata-2016:
+ ;; <https://github.com/eggert/tz/commit/4368251ebf11310a4aadccd1910daeac9080c501>.
+ (substitute* "data/Locations.xml"
+ (("Asia/Rangoon")
+ "Asia/Yangon"))
#t)))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums