aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-12-30 12:57:00 -0500
committerLeo Famulari <leo@famulari.name>2018-12-30 13:09:59 -0500
commit6ec43b0d6bd950f7b03bc72c593ac598e3a1794d (patch)
treec65a6d6cd02207a6961e5c5d7d1c6006f95b9d55
parentcb3854cd114edbe529572cda740d665c2fb1c4e8 (diff)
downloadguix-6ec43b0d6bd950f7b03bc72c593ac598e3a1794d.tar
guix-6ec43b0d6bd950f7b03bc72c593ac598e3a1794d.tar.gz
gnu: OpenSSL 1.1: Update to 1.1.1a [fixes CVE-2018-{0734,0735}].
* gnu/packages/tls.scm (openssl-next): Update to 1.1.1a.
-rw-r--r--gnu/packages/tls.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 036736498d..09bc4b4117 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -394,7 +394,7 @@ required structures.")
(package
(inherit openssl)
(name "openssl")
- (version "1.1.1")
+ (version "1.1.1a")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -407,16 +407,16 @@ required structures.")
(patches (search-patches "openssl-1.1-c-rehash-in.patch"))
(sha256
(base32
- "0gbab2fjgms1kx5xjvqx8bxhr98k4r8l2fa8vw7kvh491xd8fdi8"))))
+ "0hcz7znzznbibpy3iyyhvlqrq44y88plxwdj32wjzgbwic7i687w"))))
(outputs '("out"
- "doc" ; 6.7 MiB of man3 pages and full HTML documentation
+ "doc" ; 6.8 MiB of man3 pages and full HTML documentation
"static")) ; 6.4 MiB of .a files
(arguments
(substitute-keyword-arguments (package-arguments openssl)
((#:phases phases)
`(modify-phases ,phases
(delete 'patch-tests) ; These two phases are not needed by
- (delete 'patch-Makefile.org) ; OpenSSL 1.1.0.
+ (delete 'patch-Makefile.org) ; OpenSSL 1.1.
;; Override configure phase since -rpath is now a configure option.
(replace 'configure