aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-11-16 21:44:05 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-11-18 11:29:38 +0100
commit5fb3e8221767d3c2296c2d2709e10d8b3835a137 (patch)
treeeb709c9a524eeeb1ed148972ad9067f68a563e9b
parent965ba54be0674de7d84430622ec35b0de24c7334 (diff)
downloadguix-5fb3e8221767d3c2296c2d2709e10d8b3835a137.tar
guix-5fb3e8221767d3c2296c2d2709e10d8b3835a137.tar.gz
gnu: Add java-jboss-jms-api-spec.
* gnu/packages/java.scm (java-jboss-jms-api-spec): New variable.
-rw-r--r--gnu/packages/java.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 6ac4a37863..f31724538c 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6883,3 +6883,29 @@ done to the IDE or continuous integration servers which simplifies adoption.")
("reflect" ,java-powermock-reflect)
("support" ,java-powermock-api-support)
("cglib" ,java-cglib)))))
+
+(define-public java-jboss-jms-api-spec
+ (package
+ (name "java-jboss-jms-api-spec")
+ (version "2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/jboss/jboss-jms-api_spec/"
+ "archive/jboss-jms-api_" version
+ "_spec-1.0.1.Final.tar.gz"))
+ (sha256
+ (base32
+ "07bqblw9kq2i8q92bz70fvavq5xjfkaixl8xa0m0cypjgy82rb7m"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "java-jboss-jms-api_spec.jar"
+ #:jdk ,icedtea-8
+ #:source-dir "."
+ #:tests? #f)); no tests
+ (home-page "https://github.com/jboss/jboss-jms-api_spec")
+ (synopsis "Java Message Service API specification")
+ (description "Java Message Service (JMS) API is used to send messages
+messages between two or more clients. It is a messaging standard that allows
+application components to create, send, receive, and read messages.")
+ ; either gpl2 only with GPL Classpath Exception, or cddl.
+ (license (list license:gpl2 license:cddl1.0))))