aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:53:38 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:53 +0000
commit57e73ed7ac820f6920667c3381498b5ea4928bfa (patch)
tree23907c01c28fd8248062f52de78c388a0618b70c
parent7c264a2a754af1c41088069ddf3afd62baf27217 (diff)
downloadguix-57e73ed7ac820f6920667c3381498b5ea4928bfa.tar
guix-57e73ed7ac820f6920667c3381498b5ea4928bfa.tar.gz
gnu: Add python-pyprint.
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b65447113f..d0ae1006a6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15094,3 +15094,29 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"A collection of helpers and mock objects for unit tests and doc tests.")
(license license:expat)))
+
+(define-public python-pyprint
+ (package
+ (name "python-pyprint")
+ (version "0.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyPrint" version))
+ (sha256
+ (base32
+ "1qmhcz8n9rnxkj2ikcc208900yg4p9qglhw50br7carr1ca1q3ps"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-termcolor" ,python-termcolor)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "")
+ (synopsis
+ "A library providing printing facilities for python applications.")
+ (description
+ "A library providing printing facilities for python applications.")
+ (license #f)))