aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-28 09:58:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-28 09:58:56 +0200
commit4bc00b563162edf35c56641472aef258076eeaab (patch)
tree1dfb64a99d03ba057d17e8f654c9621146ce7884
parent54d6096255e22c19e3b1c1af494d401c1982c414 (diff)
downloadguix-4bc00b563162edf35c56641472aef258076eeaab.tar
guix-4bc00b563162edf35c56641472aef258076eeaab.tar.gz
gnu: wget: Enable previously failing test.
* gnu/packages/wget.scm (wget)[arguments]: Remove custom phase skipping SSL tests.
-rw-r--r--gnu/packages/wget.scm15
1 files changed, 0 insertions, 15 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index c0c53db29c..49bc6ecea7 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -55,21 +55,6 @@
(base32
"0a29qsqxkk8145vkyy35q5a1wc7qzwx3qj3gmfrkmi9xs96yhqqg"))))
(build-system gnu-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (add-before 'check 'disable-https-tests
- (lambda _
- ;; XXX: Skip TLS tests, which fail with "The
- ;; certificate's owner does not match hostname" as
- ;; reported at:
- ;; <https://lists.gnu.org/archive/html/bug-wget/2017-07/msg00012.html>.
- ;; The problem appears to be due to a change in GnuTLS
- ;; 3.5.12, whereby 'gnutls_x509_crt_check_hostname2' no
- ;; longer matches IP address against the 'CN' or
- ;; 'DNSname' fields of certificates.
- (substitute* "testenv/Makefile"
- (("SSL_TESTS=1") ""))
- #t)))))
(inputs
`(("gnutls" ,gnutls)
("libidn2" ,libidn2)