aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:57:51 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:54 +0000
commit45561d91b4b2c8323a3f8f5acaee9761793b1d13 (patch)
tree13178afb6ced35ff02220f79e4128799cb667519
parentefac98e234b77cc89492a265a58180cffab6a978 (diff)
downloadguix-45561d91b4b2c8323a3f8f5acaee9761793b1d13.tar
guix-45561d91b4b2c8323a3f8f5acaee9761793b1d13.tar.gz
gnu: Add python-scspell3k.
-rw-r--r--gnu/packages/python.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index babf106ac1..0c7bd85428 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15622,3 +15622,22 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"Safety checks your installed dependencies for known security vulnerabilities.")
(license license:expat)))
+
+(define-public python-scspell3k
+ (package
+ (name "python-scspell3k")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "scspell3k" version))
+ (sha256
+ (base32
+ "02dp70ikvb2yw839cycjksyi1izvfjlwjps74fh3279asa59m2d9"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/myint/scspell")
+ (synopsis
+ "A conservative interactive spell checker for source code.")
+ (description
+ "A conservative interactive spell checker for source code.")
+ (license #f)))