aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-08-29 09:24:34 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-07 11:40:06 +0200
commit40c10917bc3b8df853001c193da882d643db1bd1 (patch)
tree0789bdbfde243b823a46338e43be0f14f881eed3
parent12498b59e76c0285f0d9babb0107e8e82855aa60 (diff)
downloadguix-40c10917bc3b8df853001c193da882d643db1bd1.tar
guix-40c10917bc3b8df853001c193da882d643db1bd1.tar.gz
gnu: Add r-abcp2.
* gnu/packages/cran.scm (r-abcp2): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 447be5657a..c713a9904b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5411,3 +5411,24 @@ maximum cycle number. The @code{r-abcoptim} implements the Artificial bee
colony optimization algorithm @url{http://mf.erciyes.edu.tr/abc/pub/tr06_2005.pdf}.
This version is a work-in-progress and is written in R code.")
(license license:expat)))
+
+(define-public r-abcp2
+ (package
+ (name "r-abcp2")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ABCp2" version))
+ (sha256
+ (base32 "1s2skkxpzss7c29i8600psgrp0hl46jcrxqrmy2b4db8hc0kcnbx"))))
+ (properties `((upstream-name . "ABCp2")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-mass" ,r-mass)))
+ (home-page "https://cran.r-project.org/web/packages/ABCp2/")
+ (synopsis "Approximate Bayesian Computational Model for Estimating P2")
+ (description
+ "This package tests the goodness of fit of a distribution of offspring to the Normal,
+Poisson, and Gamma distribution and estimates the proportional paternity of the
+second male (P2) based on the best fit distribution.")
+ (license license:gpl2)))