aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-17 11:23:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-17 13:13:10 +0200
commit24d6cc1d59fa9a4e6ead491d9db27bac99e8081b (patch)
tree38235196247a99a7455cba7cad54f00569c401f2
parent773899112b39da062d7905a57681c4cd112d77fe (diff)
downloadguix-24d6cc1d59fa9a4e6ead491d9db27bac99e8081b.tar
guix-24d6cc1d59fa9a4e6ead491d9db27bac99e8081b.tar.gz
gnu: Use HTTPS for gtk.org.
* gnu/packages/gimp.scm (babl)[source]: Use HTTPS for ftp.gtk.org. * gnu/packages/gnome.scm (rest)[home-page]: Use HTTPS for www.gtk.org. * gnu/packages/gtk.scm (gtk+-2, gtk-doc)[home-page]: Likewise.
-rw-r--r--gnu/packages/gimp.scm2
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/gtk.scm4
3 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index feb67318df..766fd03dcd 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -54,7 +54,7 @@
(uri (list (string-append "https://download.gimp.org/pub/babl/"
(version-major+minor version)
"/babl-" version ".tar.bz2")
- (string-append "http://ftp.gtk.org/pub/babl/"
+ (string-append "https://ftp.gtk.org/pub/babl/"
(version-major+minor version)
"/babl-" version ".tar.bz2")
(string-append "ftp://ftp.gtk.org/pub/babl/"
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fe26bc35cc..c87df98613 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2444,7 +2444,7 @@ library.")
`(("glib" ,glib)
("libsoup" ,libsoup)
("libxml2" ,libxml2)))
- (home-page "http://www.gtk.org/")
+ (home-page "https://www.gtk.org/")
(synopsis "RESTful web api query library")
(description
"This library was designed to make it easier to access web services that
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 429b0579c8..8b11e3fb1f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -664,7 +664,7 @@ graphical user interfaces. Offering a complete set of widgets, GTK+ is
suitable for projects ranging from small one-off tools to complete
application suites.")
(license license:lgpl2.0+)
- (home-page "http://www.gtk.org/")))
+ (home-page "https://www.gtk.org/")))
(define-public gtk+
(package (inherit gtk+-2)
@@ -1492,7 +1492,7 @@ information.")
("source-highlight" ,source-highlight)
("glib" ,glib)
("python-six" ,python-six)))
- (home-page "http://www.gtk.org/gtk-doc/")
+ (home-page "https://www.gtk.org/gtk-doc/")
(synopsis "Documentation generator from C source code")
(description
"GTK-Doc generates API documentation from comments added to C code. It is