aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-10-19 15:09:55 +0200
committerRoel Janssen <roel@gnu.org>2016-10-19 15:09:55 +0200
commit207ce8fbe5a906789aafa4d337675c627ce592d8 (patch)
treece15661efd7c547c469f64ad15ae5a16988b5f0a
parentb747718e230eba267ae158d03d506527bfe1a67a (diff)
downloadguix-207ce8fbe5a906789aafa4d337675c627ce592d8.tar
guix-207ce8fbe5a906789aafa4d337675c627ce592d8.tar.gz
gnu: Add r-biocviews.
* gnu/packages/bioinformatics.scm (r-biocviews): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 00770e8fbb..d58227408c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5888,6 +5888,34 @@ packages.")
Bioconductor, CRAN, and Github.")
(license license:artistic2.0)))
+(define-public r-biocviews
+ (package
+ (name "r-biocviews")
+ (version "1.42.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "biocViews" version))
+ (sha256
+ (base32
+ "07rjk10b91pkriyq297w86199r2d3sfji3ggs9mq2gyalsa8y4b6"))))
+ (properties
+ `((upstream-name . "biocViews")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-graph" ,r-graph)
+ ("r-rbgl" ,r-rbgl)
+ ("r-rcurl" ,r-rcurl)
+ ("r-xml" ,r-xml)
+ ("r-knitr" ,r-knitr)
+ ("r-runit" ,r-runit)))
+ (home-page "http://bioconductor.org/packages/biocViews")
+ (synopsis "Bioconductor package categorization helper")
+ (description "The purpose of biocViews is to create HTML pages that
+categorize packages in a Bioconductor package repository according to keywords,
+also known as views, in a controlled vocabulary.")
+ (license license:artistic2.0)))
+
(define-public r-getopt
(package
(name "r-getopt")