aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:56:50 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:54 +0000
commit113e412b8b0faa123fa70a0185da7e8b20ce41b7 (patch)
tree348b2be385524eadac86663aeab2128bf29740b4
parentb18f875f20daf0a92471194407c2f0f05c3aa41b (diff)
downloadguix-113e412b8b0faa123fa70a0185da7e8b20ce41b7.tar
guix-113e412b8b0faa123fa70a0185da7e8b20ce41b7.tar.gz
gnu: Add python-pydocstyle.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 381c686a39..5d21236d2f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15482,3 +15482,26 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(synopsis "A linter for prose")
(description "A linter for prose")
(license license:bsd-3)))
+
+(define-public python-pydocstyle
+ (package
+ (name "python-pydocstyle")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pydocstyle" version))
+ (sha256
+ (base32
+ "15ssv8l6cvrmzgwcdzw76rnl4np3qf0dbwr1wsx76y0hc7lwsnsd"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-configparser" ,python-configparser)
+ ("python-six" ,python-six)
+ ("python-snowballstemmer"
+ ,python-snowballstemmer)))
+ (home-page
+ "https://github.com/PyCQA/pydocstyle/")
+ (synopsis "Python docstring style checker")
+ (description "Python docstring style checker")
+ (license license:expat)))