aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-11-05 17:43:59 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-11-18 11:30:03 +0100
commit0b54e190abad251e877a7b371e7e7d3142e7b633 (patch)
treeca43794ade12821a5d3cb91e7904774f8fcd8677
parent2caf873e86db49a8807d938f3959beb9a7025447 (diff)
downloadguix-0b54e190abad251e877a7b371e7e7d3142e7b633.tar
guix-0b54e190abad251e877a7b371e7e7d3142e7b633.tar.gz
gnu: Add java-jdom.
* gnu/packages/java.scm (java-jdom): New variable.
-rw-r--r--gnu/packages/java.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 9f8e504a8d..befc8a217e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -7227,3 +7227,28 @@ protocol-independent framework to build mail and messaging applications.")
;; Either cddl or gpl2 only.
(license (list license:cddl1.1; actually cddl1.1
license:gpl2)))); with classpath exception
+
+(define-public java-jdom
+ (package
+ (name "java-jdom")
+ (version "1.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://jdom.org/dist/binary/archive/jdom-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "07wdpm3jwwc9q38kmdw40fvbmv6jzjrkrf8m0zqs58f79a672wfl"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:build-target "package"
+ #:tests? #f; tests are run as part of the build process
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (install-jars "build")))))
+ (home-page "http://jdom.org/")
+ (synopsis "Access, manipulate, and output XML data")
+ (description "Java-based solution for accessing, manipulating, and
+outputting XML data from Java code.")
+ (license license:bsd-4)))