aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-01-23 08:33:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-01-23 21:18:21 +0100
commit04ba7a9db6c956ae39b6bff0835b9d531e0c269c (patch)
tree9d0be20def3afc1f73f3e4105c2114ff07cb27ec
parentce018d16f1ebae914220e2351487b43cb7254442 (diff)
downloadguix-04ba7a9db6c956ae39b6bff0835b9d531e0c269c.tar
guix-04ba7a9db6c956ae39b6bff0835b9d531e0c269c.tar.gz
gnu: powertabeditor: Fix build.
* gnu/packages/music.scm (powertabeditor)[arguments]: Add phase "fix-boost-bug" to fix build with boost 1.64.
-rw-r--r--gnu/packages/music.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f81d4f5069..e399c0293d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1181,6 +1181,14 @@ add_library( rapidjson INTERFACE IMPORTED )"))
"exclude:Score/ViewFilter/ViewFilter"
"exclude:Formats/PowerTabOldImport/Directions"
))))
+ ;; FIXME: This bug has been fixed upstream, but no release has been
+ ;; made yet. See https://github.com/powertab/powertabeditor/issues/257
+ (add-after 'unpack 'fix-boost-bug
+ (lambda _
+ (substitute* "source/score/voiceutils.cpp"
+ (("boost::rational<int> duration\\(4, pos.getDurationType\\(\\)\\);")
+ "boost::rational<int> duration(4, static_cast<int>(pos.getDurationType()));"))
+ #t))
(add-before 'configure 'remove-third-party-libs
(lambda* (#:key inputs #:allow-other-keys)
;; Link with required static libraries, because we're not