aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Antoine Rouby <contact@parouby.fr>2018-11-20 17:46:24 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-27 12:08:25 +0100
commit039ccc7118b0a6d0cb09e9cab5caf9f629197d03 (patch)
tree436ac98b1dbae94f68b15b5b126d05c270a53d79
parent5923102f7b58f0a0120926ec5b81ed48b26a188e (diff)
downloadguix-039ccc7118b0a6d0cb09e9cab5caf9f629197d03.tar
guix-039ccc7118b0a6d0cb09e9cab5caf9f629197d03.tar.gz
gnu: Add guile-mastodon.
* gnu/packages/guile.scm (guile-mastodon): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 5a3ce44016..07b568ee7c 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -2329,4 +2329,33 @@ Scheme by using Guile’s foreign function interface.")
(home-page "https://gitlab.com/mothacehe/guile-newt")
(license license:gpl3+))))
+(define-public guile-mastodon
+ (package
+ (name "guile-mastodon")
+ (version "0.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://framagit.org/prouby/guile-mastodon.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vblf3d1bbwna3l09p2ap5y8ycvl549bz6whgk78imyfmn28ygry"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.2)
+ ("gnutls" ,gnutls)
+ ("guile-json" ,guile-json)))
+ (home-page "https://framagit.org/prouby/guile-mastodon")
+ (synopsis "Guile Mastodon REST API module")
+ (description "This package provides Guile modules to access the
+@uref{https://docs.joinmastodon.org/api/, REST API of Mastodon}, a federated
+microblogging service.")
+ (license license:gpl3+)))
+
;;; guile.scm ends here