aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-21 23:05:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-21 23:06:47 +0200
commitf8ee22fc8b486612a9f041bb351d99ba0ce16dc0 (patch)
treec98d86562b2c8cf56ded2087c13c925607f91ac5
parent4d93a9a36c3ddc431789fa38201b0fd657412dbe (diff)
downloadguix-f8ee22fc8b486612a9f041bb351d99ba0ce16dc0.tar
guix-f8ee22fc8b486612a9f041bb351d99ba0ce16dc0.tar.gz
gnu: flexbar: Update to 3.4.0.
* gnu/packages/bioinformatics.scm (flexbar): Update to 3.4.0. [source]: Fetch from git. [arguments]: Adjust check and install phases. [home-page]: Update to new home at Github. [license]: Change to bsd-3.
-rw-r--r--gnu/packages/bioinformatics.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cdb82aee8b..96ea07bdc4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2607,38 +2607,39 @@ results. The FASTX-Toolkit tools perform some of these preprocessing tasks.")
(define-public flexbar
(package
(name "flexbar")
- (version "2.5")
+ (version "3.4.0")
(source (origin
- (method url-fetch)
- (uri
- (string-append "mirror://sourceforge/flexbar/"
- version "/flexbar_v" version "_src.tgz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/seqan/flexbar.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "13jaykc3y1x8y5nn9j8ljnb79s5y51kyxz46hdmvvjj6qhyympmf"))))
+ "1pq9sxvdnldl14libk234m72dqhwgzs3acgl943wchwdqlcsi5r2"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags (list
- (string-append "-DFLEXBAR_BINARY_DIR="
- (assoc-ref %outputs "out")
- "/bin/"))
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key outputs #:allow-other-keys)
- (setenv "PATH" (string-append
- (assoc-ref outputs "out") "/bin:"
- (getenv "PATH")))
- (chdir "../flexbar_v2.5_src/test")
- (zero? (system* "bash" "flexbar_validate.sh"))))
- (delete 'install))))
+ (setenv "PATH" (string-append (getcwd) ":" (getenv "PATH")))
+ (with-directory-excursion "../source/test"
+ (invoke "bash" "flexbar_test.sh"))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (string-append (assoc-ref outputs "out")))
+ (bin (string-append out "/bin/")))
+ (install-file "flexbar" bin))
+ #t)))))
(inputs
`(("tbb" ,tbb)
("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
("seqan" ,seqan)))
- (home-page "http://flexbar.sourceforge.net")
+ (home-page "https://github.com/seqan/flexbar")
(synopsis "Barcode and adapter removal tool for sequencing platforms")
(description
"Flexbar preprocesses high-throughput nucleotide sequencing data
@@ -2647,7 +2648,7 @@ Moreover, trimming and filtering features are provided. Flexbar increases
read mapping rates and improves genome and transcriptome assemblies. It
supports next-generation sequencing data in fasta/q and csfasta/q format from
Illumina, Roche 454, and the SOLiD platform.")
- (license license:gpl3)))
+ (license license:bsd-3)))
(define-public fraggenescan
(package