aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-21 21:11:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-21 23:06:46 +0200
commitc96ca68f31619ed678720fc1dc6bbf0906ce5638 (patch)
tree93d55e913685930c85f975ea6cc0e1dffbc3d6e0
parent949fa34b84ce8c8027e568878db648c20ff37a5c (diff)
downloadguix-c96ca68f31619ed678720fc1dc6bbf0906ce5638.tar
guix-c96ca68f31619ed678720fc1dc6bbf0906ce5638.tar.gz
gnu: edirect: Update to 10.2.20181018.
* gnu/packages/bioinformatics.scm (edirect): Update to 10.2.20181018. [arguments]: Add simple check phase; simplify other phases. [inputs]: Add perl-xml-simple.
-rw-r--r--gnu/packages/bioinformatics.scm46
1 files changed, 26 insertions, 20 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d0f4429a4c..a806fd5f22 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2335,36 +2335,41 @@ quantitative phenotypes.")
(define-public edirect
(package
(name "edirect")
- (version "4.10")
+ (version "10.2.20181018")
(source (origin
(method url-fetch)
- (uri (string-append "ftp://ftp.ncbi.nlm.nih.gov/entrez/entrezdirect/"
- "versions/2016-05-03/edirect.tar.gz"))
+ (uri (string-append "ftp://ftp.ncbi.nlm.nih.gov/entrez/entrezdirect"
+ "/versions/" version
+ "/edirect-" version ".tar.gz"))
(sha256
(base32
- "15zsprak5yh8c1yrz4r1knmb5s8qcmdid4xdhkh3lqcv64l60hli"))))
+ "091f4aigzpbqih6h82nq566gkp3y07i72yqndmqskfgar1vwgci7"))))
(build-system perl-build-system)
(arguments
- `(#:tests? #f ;no "check" target
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(delete 'configure)
(delete 'build)
+ (delete 'check) ; simple check after install
(replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((target (string-append (assoc-ref outputs "out")
- "/bin")))
- (mkdir-p target)
- (install-file "edirect.pl" target)
- #t)))
- (add-after
- 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Make sure 'edirect.pl' finds all perl inputs at runtime.
- (let* ((out (assoc-ref outputs "out"))
- (path (getenv "PERL5LIB")))
- (wrap-program (string-append out "/bin/edirect.pl")
- `("PERL5LIB" ":" prefix (,path)))))))))
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "edirect.pl"
+ (string-append (assoc-ref outputs "out") "/bin"))
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure 'edirect.pl' finds all perl inputs at runtime.
+ (let* ((out (assoc-ref outputs "out"))
+ (path (getenv "PERL5LIB")))
+ (wrap-program (string-append out "/bin/edirect.pl")
+ `("PERL5LIB" ":" prefix (,path))))
+ #t))
+ (add-after 'wrap-program 'check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke (string-append (assoc-ref outputs "out")
+ "/bin/edirect.pl")
+ "-filter" "-help")
+ #t)))))
(inputs
`(("perl-html-parser" ,perl-html-parser)
("perl-encode-locale" ,perl-encode-locale)
@@ -2380,6 +2385,7 @@ quantitative phenotypes.")
("perl-net-http" ,perl-net-http)
("perl-uri" ,perl-uri)
("perl-www-robotrules" ,perl-www-robotrules)
+ ("perl-xml-simple" ,perl-xml-simple)
("perl" ,perl)))
(home-page "http://www.ncbi.nlm.nih.gov/books/NBK179288/")
(synopsis "Tools for accessing the NCBI's set of databases")