aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-21 12:42:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-21 23:06:45 +0200
commit8640f9ec91f7a9e81457a3651a06465fd8dd03a3 (patch)
treecb161a9916f6f1c52b2bde422d7f225901efb3ee
parentf5cec0068a7e6f9ca1b7542d1839b832ee057648 (diff)
downloadguix-8640f9ec91f7a9e81457a3651a06465fd8dd03a3.tar
guix-8640f9ec91f7a9e81457a3651a06465fd8dd03a3.tar.gz
gnu: python-twobitreader: Update to 3.1.6.
* gnu/packages/bioinformatics.scm (python-twobitreader): Update to 3.1.6. [source]: Fetch from git.
-rw-r--r--gnu/packages/bioinformatics.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7cd9172446..795b0f208e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1595,19 +1595,19 @@ also includes an interface for tabix.")
(define-public python-twobitreader
(package
(name "python-twobitreader")
- (version "3.1.4")
+ (version "3.1.6")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "twobitreader" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/benjschiller/twobitreader")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1q8wnj2kga9nz1lwc4w7qv52smfm536hp6mc8w6s53lhyj0mpi22"))))
+ "1qbxvv1h58cismbk1anpjrkpghsaiy64a11ir3lhy6qch6xf8n62"))))
(build-system python-build-system)
- (arguments
- '(;; Tests are not distributed in the PyPi release.
- ;; TODO Try building from the Git repo or asking the upstream maintainer
- ;; to distribute the tests on PyPi.
- #:tests? #f))
+ ;; Tests are not included
+ (arguments '(#:tests? #f))
(native-inputs
`(("python-sphinx" ,python-sphinx)))
(home-page "https://github.com/benjschiller/twobitreader")