aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-21 22:58:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-21 23:06:47 +0200
commit50e33c3a8c591af8a6112ea42d53ed6f0ec80208 (patch)
tree53dfc68b1537942c3f7a0cad0368241de9b00fa4
parent0db75f7a79126a368e0c8fb2d71abf76da065a3f (diff)
downloadguix-50e33c3a8c591af8a6112ea42d53ed6f0ec80208.tar
guix-50e33c3a8c591af8a6112ea42d53ed6f0ec80208.tar.gz
gnu: python-screed: Update to 1.0.
* gnu/packages/bioinformatics.scm (python-screed): Update to 1.0. [arguments]: Run tests after installation. [native-inputs]: Add python-pytest, python-pytest-cov, and python-pytest-runner; remove python-nose.
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 22 insertions, 9 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a99deeb0a6..9afb2c1197 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5602,25 +5602,38 @@ complexity samples.")
(define-public python-screed
(package
(name "python-screed")
- (version "0.9")
+ (version "1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "screed" version))
(sha256
(base32
- "18czszp9fkx3j6jr7y5kp6dfialscgddk05mw1zkhh2zhn0jd8i0"))))
+ "148vcb7w2wr6a4w6vs2bsxanbqibxfk490zbcbg4m61s8669zdjx"))))
(build-system python-build-system)
(arguments
- `(#:phases
+ '(#:phases
(modify-phases %standard-phases
- (replace 'check
- (lambda _
- (setenv "PYTHONPATH"
- (string-append (getenv "PYTHONPATH") ":."))
- (zero? (system* "nosetests" "--attr" "!known_failing")))))))
+ ;; Tests must be run after installation, as the "screed" command does
+ ;; not exist right after building.
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "PYTHONPATH"
+ (string-append out "/lib/python"
+ (string-take (string-take-right
+ (assoc-ref inputs "python")
+ 5) 3)
+ "/site-packages:"
+ (getenv "PYTHONPATH")))
+ (setenv "PATH" (string-append out "/bin:" (getenv "PATH"))))
+ (invoke "python" "setup.py" "test")
+ #t)))))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-runner" ,python-pytest-runner)))
(inputs
`(("python-bz2file" ,python-bz2file)))
(home-page "https://github.com/dib-lab/screed/")