aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-21 20:51:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-21 23:06:46 +0200
commit49b2e86adf2b0788c627120ae4c3cf55d3eb9afa (patch)
tree8f36f7ca14f79201f5ec4a66e2edb5c243e75317
parent1c0639935809cc64150192517c58d95411748407 (diff)
downloadguix-49b2e86adf2b0788c627120ae4c3cf55d3eb9afa.tar
guix-49b2e86adf2b0788c627120ae4c3cf55d3eb9afa.tar.gz
gnu: Add texlive-latex-doi.
* gnu/packages/tex.scm (texlive-latex-doi): New variable.
-rw-r--r--gnu/packages/tex.scm40
1 files changed, 39 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6a76cbf866..e4c307e54f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -2274,6 +2274,44 @@ space-stripped macros.")
to something that's not a float.")
(license license:lppl)))
+(define-public texlive-latex-doi
+ (package
+ (name "texlive-latex-doi")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/doi"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0378rdmrgr2lzbfi4qqy4dfpj5im20diyd8z8b9m4mlg05r7wgnb"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/doi")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "https://www.ctan.org/pkg/doi")
+ (synopsis "Create correct hyperlinks for DOI numbers")
+ (description
+ "You can hyperlink DOI numbers to doi.org. However, some publishers have
+elected to use nasty characters in their DOI numbering scheme (@code{<},
+@code{>}, @code{_} and @code{;} have all been spotted). This will either
+upset LaTeX, or your PDF reader. This package contains a single user-level
+command @code{\\doi{}}, which takes a DOI number, and creates a correct
+hyperlink to the target of the DOI.")
+ ;; Any version of the LPPL.
+ (license license:lppl1.3+)))
+
(define-public texlive-latex-etoolbox
(package
(name "texlive-latex-etoolbox")