aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-21 20:53:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-21 23:06:46 +0200
commit4348a059e527969b55875ad33525d6023cd82201 (patch)
tree83964c5680cf33556687bb968b19a2522b417b3d
parentf50f343e0d138adb328132fb6e17f170261b8798 (diff)
downloadguix-4348a059e527969b55875ad33525d6023cd82201.tar
guix-4348a059e527969b55875ad33525d6023cd82201.tar.gz
gnu: Add texlive-latex-examplep.
* gnu/packages/tex.scm (texlive-latex-examplep): New variable.
-rw-r--r--gnu/packages/tex.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 46f013b7db..f8b11f7e1a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4885,3 +4885,44 @@ a replica of the @code{boxedverbatim} environment itself). A valuable use is
in places where the standard @code{verbatim} environment (which is based on a
@code{trivlist}) may not appear.")
(license license:lppl1.3+)))
+
+(define-public texlive-latex-examplep
+ (package
+ (name "texlive-latex-examplep")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/examplep"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0fsvvmz68ij0zwfzrny6x13d92grxr4ap59lxgah4smbkccd6s27"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/examplep")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "https://www.ctan.org/pkg/examplep")
+ (synopsis "Verbatim phrases and listings in LaTeX")
+ (description
+ "Examplep provides sophisticated features for typesetting verbatim source
+code listings, including the display of the source code and its compiled LaTeX
+or METAPOST output side-by-side, with automatic width detection and enabled
+page breaks (in the source), without the need for specifying the source twice.
+Special care is taken that section, page and footnote numbers do not interfere
+with the main document. For typesetting short verbatim phrases, a replacement
+for the @code{\\verb} command is also provided in the package, which can be
+used inside tables and moving arguments such as footnotes and section
+titles.")
+ ;; No version of the GPL is specified.
+ (license license:gpl3+)))