aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-21 13:43:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-21 23:06:46 +0200
commit42643fc24dd1f418f5f2e0991181d526c0419c1a (patch)
tree843d953b6667622e5043db9fc33f3601ca6e1474
parent6b31040ae6865436c1a21378a8b9a09e25ec4adc (diff)
downloadguix-42643fc24dd1f418f5f2e0991181d526c0419c1a.tar
guix-42643fc24dd1f418f5f2e0991181d526c0419c1a.tar.gz
gnu: python-dendropy: Fetch from git.
* gnu/packages/bioinformatics.scm (python-dendropy)[source]: Fetch from git.
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index feb4928a93..60e8f6e55a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2053,15 +2053,15 @@ accessing bigWig files.")
(version "4.4.0")
(source
(origin
- (method url-fetch)
+ (method git-fetch)
;; Source from GitHub so that tests are included.
- (uri
- (string-append "https://github.com/jeetsukumaran/DendroPy/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/jeetsukumaran/DendroPy.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0v2fccny5xjaah546bsch1mw4kh61qq5frz2ibllxs9mp6ih9bsn"))))
+ "097hfyv2kaf4x92i4rjx0paw2cncxap48qivv8zxng4z7nhid0x9"))))
(build-system python-build-system)
(home-page "http://packages.python.org/DendroPy/")
(synopsis "Library for phylogenetics and phylogenetic computing")