aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-20 23:04:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-20 23:37:34 +0200
commit21c837405a7d46590fbe1d9e45e16a56f182e451 (patch)
tree4f012ea841984c2b0bd1e7c427c2594d69cddc0d
parentf45093429c8319475b22c5478ea6b719b7c97cb8 (diff)
downloadguix-21c837405a7d46590fbe1d9e45e16a56f182e451.tar
guix-21c837405a7d46590fbe1d9e45e16a56f182e451.tar.gz
gnu: bowtie: Update to 2.3.4.3.
* gnu/packages/bioinformatics.scm (bowtie): Update to 2.3.4.3. [source]: Fetch from git. [inputs]: Replace python-2 with python-wrapper; move perl, perl-clone, perl-test-deep, and perl-test-simple from here... [native-inputs]: ...to here. [arguments]: Simplify check phase.
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 22 insertions, 19 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 66e06869c4..7c58ab2455 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1273,15 +1273,16 @@ errors at the end of reads.")
(define-public bowtie
(package
(name "bowtie")
- (version "2.3.2")
+ (version "2.3.4.3")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/BenLangmead/bowtie2/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BenLangmead/bowtie2.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0hwa5r9qbglppb7sz5z79rlmmddr3n51n468jb3wh8rwjgn3yr90"))
+ "1zl3cf327y2p7p03cavymbh7b00djc7lncfaqih33n96iy9q8ibp"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1291,14 +1292,6 @@ errors at the end of reads.")
(("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\""))
#t))))
(build-system gnu-build-system)
- (inputs
- `(("perl" ,perl)
- ("perl-clone" ,perl-clone)
- ("perl-test-deep" ,perl-test-deep)
- ("perl-test-simple" ,perl-test-simple)
- ("python" ,python-2)
- ("tbb" ,tbb)
- ("zlib" ,zlib)))
(arguments
'(#:make-flags
(list "allall"
@@ -1308,11 +1301,21 @@ errors at the end of reads.")
(modify-phases %standard-phases
(delete 'configure)
(replace 'check
- (lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "perl"
- "scripts/test/simple_tests.pl"
- "--bowtie2=./bowtie2"
- "--bowtie2-build=./bowtie2-build")))))))
+ (lambda _
+ (invoke "perl"
+ "scripts/test/simple_tests.pl"
+ "--bowtie2=./bowtie2"
+ "--bowtie2-build=./bowtie2-build")
+ #t)))))
+ (inputs
+ `(("tbb" ,tbb)
+ ("zlib" ,zlib)
+ ("python" ,python-wrapper)))
+ (native-inputs
+ `(("perl" ,perl)
+ ("perl-clone" ,perl-clone)
+ ("perl-test-deep" ,perl-test-deep)
+ ("perl-test-simple" ,perl-test-simple)))
(home-page "http://bowtie-bio.sourceforge.net/bowtie2/index.shtml")
(synopsis "Fast and sensitive nucleotide sequence read aligner")
(description