aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-21 21:30:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-21 23:06:46 +0200
commit0db75f7a79126a368e0c8fb2d71abf76da065a3f (patch)
treeb960437f0a9727dba3ec13b5ec570ac6ba3079b1
parent38622ccd14c5d2df152ff8d72f1f5269afb36565 (diff)
downloadguix-0db75f7a79126a368e0c8fb2d71abf76da065a3f.tar
guix-0db75f7a79126a368e0c8fb2d71abf76da065a3f.tar.gz
gnu: fasttree: Use INVOKE.
* gnu/packages/bioinformatics.scm (fasttree)[arguments]: Use INVOKE; simplify install phase.
-rw-r--r--gnu/packages/bioinformatics.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9a04118588..a99deeb0a6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2537,31 +2537,30 @@ similarity of community members.")
(delete 'configure)
(replace 'build
(lambda* (#:key source #:allow-other-keys)
- (and (zero? (system* "gcc"
- "-O3"
- "-finline-functions"
- "-funroll-loops"
- "-Wall"
- "-o"
- "FastTree"
- source
- "-lm"))
- (zero? (system* "gcc"
- "-DOPENMP"
- "-fopenmp"
- "-O3"
- "-finline-functions"
- "-funroll-loops"
- "-Wall"
- "-o"
- "FastTreeMP"
- source
- "-lm")))))
+ (invoke "gcc"
+ "-O3"
+ "-finline-functions"
+ "-funroll-loops"
+ "-Wall"
+ "-o"
+ "FastTree"
+ source
+ "-lm")
+ (invoke "gcc"
+ "-DOPENMP"
+ "-fopenmp"
+ "-O3"
+ "-finline-functions"
+ "-funroll-loops"
+ "-Wall"
+ "-o"
+ "FastTreeMP"
+ source
+ "-lm")
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out")
- "/bin")))
- (mkdir-p bin)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
(install-file "FastTree" bin)
(install-file "FastTreeMP" bin)
#t))))))