aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-22 13:00:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-22 13:00:24 +0200
commit09aa3d063a0eacf3fca8d4803fbb62bd7b1ee663 (patch)
tree54ba0e0188820d09858146b189d6194df7c000a8
parent318ec0a896dff7f311d67c6ac9f1bea31efb5e3e (diff)
downloadguix-09aa3d063a0eacf3fca8d4803fbb62bd7b1ee663.tar
guix-09aa3d063a0eacf3fca8d4803fbb62bd7b1ee663.tar.gz
gnu: Add r-ruvseq.
* gnu/packages/bioconductor.scm (r-ruvseq): New variable.
-rw-r--r--gnu/packages/bioconductor.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1b779855b2..92b67453f6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -913,3 +913,29 @@ can be analyzed regarding their minimal, maximal and average distances between
barcodes. Finally, reads that start with a (possibly mutated) barcode can be
demultiplexed, i.e. assigned to their original reference barcode.")
(license license:gpl2)))
+
+(define-public r-ruvseq
+ (package
+ (name "r-ruvseq")
+ (version "1.14.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "RUVSeq" version))
+ (sha256
+ (base32
+ "16i5sm5af761k4zvspfi8jknsgln48bn538hxqqmlaq7wvlfxqxj"))))
+ (properties `((upstream-name . "RUVSeq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-edaseq" ,r-edaseq)
+ ("r-edger" ,r-edger)
+ ("r-mass" ,r-mass)))
+ (home-page "https://github.com/drisso/RUVSeq")
+ (synopsis "Remove unwanted variation from RNA-Seq data")
+ (description
+ "This package implements methods to @dfn{remove unwanted variation} (RUV)
+of Risso et al. (2014) for the normalization of RNA-Seq read counts between
+samples.")
+ (license license:artistic2.0)))