aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2018-10-04 11:05:06 -0400
committerDavid Thompson <davet@gnu.org>2018-10-04 13:21:50 -0400
commite14b3067e324f05a852d216aec5432cc285dfcec (patch)
tree28d8396ce4713ea24dd5137a3bdf52b99f6d4bd4
parentaff91b0d0bc4c4459625558dc547af3567b6e5f3 (diff)
downloadguix-e14b3067e324f05a852d216aec5432cc285dfcec.tar
guix-e14b3067e324f05a852d216aec5432cc285dfcec.tar.gz
gnu: guile-next: Add the correct native search paths.
* gnu/packages/guile.scm (guile-next): Add native search paths for version 3.0.
-rw-r--r--gnu/packages/guile.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 6d8ab71c78..04625827c5 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -355,7 +355,15 @@ without requiring the source code to be rewritten.")
(lambda _
;; Remove this test that's bound to fail.
(delete-file "test-suite/tests/version.test")
- #t)))))))))
+ #t))))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "GUILE_LOAD_PATH")
+ (files '("share/guile/site/3.0")))
+ (search-path-specification
+ (variable "GUILE_LOAD_COMPILED_PATH")
+ (files '("lib/guile/3.0/site-ccache"
+ "share/guile/site/3.0"))))))))
(define (make-guile-readline guile)
(package