aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-16 22:34:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-18 12:01:32 +0100
commitf7ce213404209cd73777834f329ddd23d72c354c (patch)
tree812af8b174038cc88ef38af034f2648590bd63ea
parent5a5d1a7f471d0f914f7d3448c9ce672f09c1cb70 (diff)
downloadguix-f7ce213404209cd73777834f329ddd23d72c354c.tar
guix-f7ce213404209cd73777834f329ddd23d72c354c.tar.gz
gnu: Add sonivox-eas.
* gnu/packages/music.scm (sonivox-eas): New variable.
-rw-r--r--gnu/packages/music.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1befaf26d5..acbb2ee7ba 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3618,3 +3618,34 @@ by The Echo Nest.")
@url{https://gpodder.net} APIs. It allows applications to discover, manage
and track podcasts.")
(license license:lgpl2.1+)))
+
+(define-public sonivox-eas
+ (package
+ (name "sonivox-eas")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pedrolcl/Linux-SonivoxEas.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0l9gs00p5g4k4qy6i7nv1mfi2n2wnsycwjrgrh9hxzam4irf2mw2"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; there are no tests
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("drumstick" ,drumstick)
+ ("pulseaudio" ,pulseaudio)
+ ("qtbase" ,qtbase)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/pedrolcl/Linux-SonivoxEas")
+ (synopsis "MIDI synthesizer library")
+ (description "This project is a real time General MIDI synthesizer based
+on the Sonivox EAS Synthesizer by Google. It does not need external
+soundfonts, using embedded samples instead.")
+ ;; Sonivox is released under the ASL2.0; the rest of the code is under
+ ;; GPLv2+.
+ (license (list license:gpl2+ license:asl2.0))))