aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-12-12 06:48:27 +0000
committerChristopher Baines <mail@cbaines.net>2017-12-17 20:46:46 +0000
commit98cf8ca89a41329c00f0e895f599901e357a60f1 (patch)
tree6ff8c41b7459d5b8b5db4d0bfa98f263510d6834
parente0d96774dd48c29ccc4c90fea1f8f71850ab0879 (diff)
downloadguix-98cf8ca89a41329c00f0e895f599901e357a60f1.tar
guix-98cf8ca89a41329c00f0e895f599901e357a60f1.tar.gz
gnu: Add mod-wsgi.
* gnu/packages/web.scm (mod-wsgi): New variable.
-rw-r--r--gnu/packages/web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index eb0436cb35..514003755c 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -145,6 +145,36 @@ and its related documentation.")
(license l:asl2.0)
(home-page "https://httpd.apache.org/")))
+(define-public mod-wsgi
+ (package
+ (name "mod-wsgi")
+ (version "4.5.22")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/GrahamDumpleton/mod_wsgi/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0n1yhmrfp8mjbsngmyjl937c6rc0069p6wdi1lknrbn1q42hzw6q"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;; TODO: Can't figure out if there are tests
+ #:make-flags (list
+ (string-append "DESTDIR="
+ (assoc-ref %outputs "out"))
+ "LIBEXECDIR=/modules")))
+ (inputs
+ `(("httpd" ,httpd)
+ ("python" ,python-wrapper)))
+ (synopsis "Apache HTTPD module for Python WSGI applications")
+ (description
+ "The mod_wsgi module for the Apache HTTPD Server adds support for running
+applications that support the Python @acronym{WSGI, Web Server Gateway
+Interface} specification.")
+ (license l:asl2.0)
+ (home-page "https://modwsgi.readthedocs.io/")))
+
(define-public nginx
(package
(name "nginx")