aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-16 23:08:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-18 12:01:33 +0100
commit92b36e3aa55dea89789c57ee5591060dc9025737 (patch)
treee415843bb851d7f7342f82338622990dceef7bd9
parentf7ce213404209cd73777834f329ddd23d72c354c (diff)
downloadguix-92b36e3aa55dea89789c57ee5591060dc9025737.tar
guix-92b36e3aa55dea89789c57ee5591060dc9025737.tar.gz
gnu: Add whysynth.
* gnu/packages/music.scm (whysynth): New variable.
-rw-r--r--gnu/packages/music.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index acbb2ee7ba..ff48d0c59f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3649,3 +3649,40 @@ soundfonts, using embedded samples instead.")
;; Sonivox is released under the ASL2.0; the rest of the code is under
;; GPLv2+.
(license (list license:gpl2+ license:asl2.0))))
+
+(define-public whysynth
+ (package
+ (name "whysynth")
+ (version "20170701")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://smbolton.com/whysynth/whysynth-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "02qbn0hbvn1iym4zxv35b201blg31yjpgh71h8db0j5zls2xc0m6"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("dssi" ,dssi)
+ ("liblo" ,liblo)
+ ("fftwf" ,fftwf)
+ ("gtk+" ,gtk+-2)
+ ("ladspa" ,ladspa)
+ ("alsa-lib" ,alsa-lib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://smbolton.com/whysynth.html")
+ (synopsis "DSSI software synthesizer")
+ (description "WhySynth is a versatile softsynth which operates as a plugin
+for the DSSI Soft Synth Interface. A brief list of features:
+
+@enumerate
+@item 4 oscillators, 2 filters, 3 LFOs, and 5 envelope generators per voice.
+@item 11 oscillator modes: minBLEP, wavecycle, chorused wavecycle,
+ asynchronous granular, three FM modes, waveshaper, noise, PADsynth, and phase
+ distortion.
+@item 10 filter modes.
+@item flexible modulation and mixdown options, plus effects.
+@end enumerate
+")
+ (license license:gpl2+)))