aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-12-15 23:30:29 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-15 23:32:02 +0100
commit86c979b7941261fb706395b83e98a8e09042343b (patch)
tree2815b04e0e83c0ac26832e2fc616be61275cac05
parent5bd3a84109caf820eeafc1d6872fc55428294f70 (diff)
downloadguix-86c979b7941261fb706395b83e98a8e09042343b.tar
guix-86c979b7941261fb706395b83e98a8e09042343b.tar.gz
gnu: hplip: Update to 3.7.11.
* gnu/packages/cups.scm (hplip): Update to 3.7.11. [source]: Add 'snippet'. [arguments]: In 'fix-hard-coded-file-names' phase, adjust hack for $(hplip_statedir) creation. [inputs]: Add ZLIB. [native-inputs]: Add PERL.
-rw-r--r--gnu/packages/cups.scm23
1 files changed, 15 insertions, 8 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index e3a252bc0c..07437af1a7 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -369,14 +369,19 @@ device-specific programs to convert and print many types of files.")
(define-public hplip
(package
(name "hplip")
- (version "3.17.10")
+ (version "3.17.11")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/hplip/hplip/" version
"/hplip-" version ".tar.gz"))
(sha256
(base32
- "0v27hg856b5z2rilczcbfgz8ksxn0n810g1glac3mxkj8qbl8wqg"))))
+ "0xda7x7xxjvzn1l0adlvbwcw21crq1r3r79bkf94q3m5i6abx49g"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Fix type mismatch.
+ '(substitute* "prnt/hpcups/genPCLm.cpp"
+ (("boolean") "bool")))))
(build-system gnu-build-system)
(home-page "http://hplipopensource.com/")
(synopsis "HP Printer Drivers")
@@ -436,11 +441,11 @@ device-specific programs to convert and print many types of files.")
(("/usr/include/libusb-1.0")
(string-append (assoc-ref inputs "libusb")
"/include/libusb-1.0"))
- (("^\tinstall-dist_hplip_stateDATA")
- ;; Remove dependencies on
- ;; 'install-dist_hplip_stateDATA' so we don't bail
- ;; out while trying to create /var/lib/hplip.
- "\t")
+ (("hplip_statedir =.*$")
+ ;; Don't bail out while trying to create
+ ;; /var/lib/hplip. We can safely change its value
+ ;; here because it's hard-coded in the code anyway.
+ "hplip_statedir = $(prefix)\n")
(("hplip_confdir = /etc/hp")
;; This is only used for installing the default config.
(string-append "hplip_confdir = " out
@@ -469,12 +474,14 @@ device-specific programs to convert and print many types of files.")
("cups-minimal" ,cups-minimal)
("libusb" ,libusb)
("sane-backends" ,sane-backends-minimal)
+ ("zlib" ,zlib)
("dbus" ,dbus)
("python-wrapper" ,python-wrapper)
("python" ,python)
;; TODO: Make hp-setup find python-dbus.
("python-dbus" ,python-dbus)))
- (native-inputs `(("pkg-config" ,pkg-config)))))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("perl" ,perl)))))
(define-public foomatic-filters
(package