aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-17 08:48:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-18 12:01:33 +0100
commit39b335849b17778d5ad7495213781064d08bb6a6 (patch)
tree849e614e355eaa1947ad63292f3b24f39318fab5
parent407137935727b6dc05d8e1a6b42af49ea93a79bc (diff)
downloadguix-39b335849b17778d5ad7495213781064d08bb6a6.tar
guix-39b335849b17778d5ad7495213781064d08bb6a6.tar.gz
gnu: Add jack-capture.
* gnu/packages/music.scm (jack-capture): New variable.
-rw-r--r--gnu/packages/music.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ff48d0c59f..39e80f9cb1 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2045,6 +2045,43 @@ on the library.")
allows you to send JACK MIDI events (i.e. play) using your PC keyboard.")
(license license:bsd-2)))
+(define-public jack-capture
+ (package
+ (name "jack-capture")
+ (version "0.9.73")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kmatheussen/jack_capture.git")
+ (commit version)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0jcqky96q8xgya6wqv1p8pj9fkf2wh7ynl67ah7x5bn3basgfclf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:tests? #f ; there are none
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("which" ,which)))
+ (inputs
+ `(("gtk+" ,gtk+-2)
+ ("jack" ,jack-1)
+ ("libogg" ,libogg)
+ ("liblo" ,liblo)
+ ("lame" ,lame)
+ ("libsndfile" ,libsndfile)))
+ (home-page "https://github.com/kmatheussen/jack_capture")
+ (synopsis "Program for recording sound files with JACK")
+ (description "This is a program for recording sound files with JACK. It
+can connect to any JACK port and record the output into a stereo WAV file.")
+ (license license:gpl2+)))
+
(define-public cursynth
(package
(name "cursynth")