aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 07:48:00 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 07:52:03 +0000
commit834c63905322ac0f8f48168cc63d3d360f499e58 (patch)
tree4c5831a2ea672a522ac55fccb553b2a8e483519e
parentd2364f179700b0ab0ccbbaa57d35adaca234fe81 (diff)
downloadguix-834c63905322ac0f8f48168cc63d3d360f499e58.tar
guix-834c63905322ac0f8f48168cc63d3d360f499e58.tar.gz
gnu: go-structlayout-optimize: Fix build.
* gnu/packages/golang-check.scm (go-structlayout-optimize) [arguments] <#:go>: Swap to go-1.20. Change-Id: I8ca2f7be5749e8f54c7decc84853ae3f665ba97c
-rw-r--r--gnu/packages/golang-check.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 380ff7e149..64e455d98f 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -704,7 +704,8 @@ flag.")))
(inherit go-honnef-co-go-tools)
(name "go-structlayout-optimize")
(arguments
- `(#:import-path "honnef.co/go/tools/cmd/structlayout-optimize"
+ `(#:go ,go-1.20
+ #:import-path "honnef.co/go/tools/cmd/structlayout-optimize"
#:unpack-path "honnef.co/go/tools"
#:install-source? #f))
(synopsis "Reorder struct fields to minimize the amount of padding in Go")