aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-02-17 14:51:13 +0000
committerLudovic Courtès <ludo@gnu.org>2022-02-18 14:14:39 +0100
commitb3d7eae08ee71674ebcf6c6dc5ef575f35493240 (patch)
treebf039ef6578040801d3cb356f21d96a043237a34
parent7168148abe08b5d21ab4d36ff2c2b8c99978e168 (diff)
downloadguix-b3d7eae08ee71674ebcf6c6dc5ef575f35493240.tar
guix-b3d7eae08ee71674ebcf6c6dc5ef575f35493240.tar.gz
gnu: upower: Update to 0.99.15.
Upstream has removed the Autotools build system and now only supports Meson, so the build system has been changed to 'meson-build-system'. The patch 'power-builddir.patch' has to be replaced to adjust to the switch to Meson. This has been done by adding an origin snippet. The origin snippet has been simplified, and for consistency, it has been made a gexp. Some dependencies were Autotools-only and could be removed. * gnu/packages/gnome.scm (upower): Update to 0.99.15. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm67
-rw-r--r--gnu/packages/patches/upower-builddir.patch34
3 files changed, 33 insertions, 69 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1252643dc0..433467ee39 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1914,7 +1914,6 @@ dist_patch_DATA = \
%D%/packages/patches/util-linux-tests.patch \
%D%/packages/patches/util-linux-CVE-2021-3995.patch \
%D%/packages/patches/util-linux-CVE-2021-3996.patch \
- %D%/packages/patches/upower-builddir.patch \
%D%/packages/patches/valgrind-enable-arm.patch \
%D%/packages/patches/vboot-utils-fix-format-load-address.patch \
%D%/packages/patches/vboot-utils-fix-tests-show-contents.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4e44145ed8..e7eac10a80 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -62,7 +62,7 @@
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
-;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021, 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Josselin Poiret <josselin.poiret@protonmail.ch>
;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
@@ -5437,55 +5437,54 @@ faster results and to avoid unnecessary server load.")
(define-public upower
(package
(name "upower")
- (version "0.99.13")
+ (version "0.99.15")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://gitlab.freedesktop.org/upower/upower")
- (commit (string-append "UPOWER_"
- (string-map (match-lambda (#\. #\_)
- (chr chr))
- version)))))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0khwg6jpq81dcylkpi7cn75bjzif0q9qscwvirrk41krma23iddj"))
- (patches (search-patches "upower-builddir.patch"))
+ (base32 "1zk7w7pw8dhlnxhxzcbk33gmxmg8f32mppd67556v9z2qgcg4lhs"))
(modules '((guix build utils)))
(snippet
- '(begin
- ;; Upstream commit
- ;; <https://cgit.freedesktop.org/upower/commit/?id=18457c99b68786cd729b315723d680e6860d9cfa>
- ;; moved 'dbus-1/system.d' from etc/ to share/. However,
- ;; 'dbus-configuration-directory' in (gnu services dbus)
- ;; expects it in etc/. Thus, move it back to its previous
- ;; location.
- (substitute* "src/Makefile.am"
- (("^dbusconfdir =.*$")
- "dbusconfdir = $(sysconfdir)/dbus-1/system.d\n"))))))
- (build-system glib-or-gtk-build-system)
+ ;; Upstream commit
+ ;; <https://cgit.freedesktop.org/upower/commit/?id=18457c99b68786cd729b315723d680e6860d9cfa>
+ ;; moved 'dbus-1/system.d' from etc/ to share/. However,
+ ;; 'dbus-configuration-directory' in (gnu services dbus)
+ ;; expects it in etc/. Thus, move it back to its previous
+ ;; location.
+ #~(substitute* "src/meson.build"
+ (("dbusdir / 'system.d'")
+ "get_option('sysconfdir') / 'dbus-1/system.d'")
+ ;; Avoid writing to /var during the build, this is
+ ;; not possible in Guix!
+ (("^install_subdir\\('does-not-exist'.*$") "")))))
+ (build-system meson-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'pre-check
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((umockdev (string-append (assoc-ref inputs "umockdev")
- "/lib")))
- (setenv "LD_LIBRARY_PATH" umockdev)))))
- #:configure-flags (list "--localstatedir=/var"
- (string-append "--with-udevrulesdir="
- (assoc-ref %outputs "out")
- "/lib/udev/rules.d"))))
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((umockdev (string-append (assoc-ref inputs "umockdev")
+ "/lib")))
+ (setenv "LD_LIBRARY_PATH" umockdev)))))
+ #:configure-flags
+ #~(list "-Dsystemdsystemunitdir=no"
+ ;; If not specified, udev will try putting history information
+ ;; in /gnu/store.
+ "-Dhistorydir=/var/lib/upower"
+ (string-append "-Dudevrulesdir=" #$output "/bin/udev/rules.d"))))
(native-inputs
- (list autoconf
- automake
+ (list `(,glib "bin") ; for gdbus-codegen
gobject-introspection
gtk-doc
intltool
- libtool
pkg-config
python
- which ; for ./autogen.sh
;; For tests.
python-dbus
python-dbusmock
diff --git a/gnu/packages/patches/upower-builddir.patch b/gnu/packages/patches/upower-builddir.patch
deleted file mode 100644
index a61d387faf..0000000000
--- a/gnu/packages/patches/upower-builddir.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 27ae011b31d831752b97eb209bc2b2206fcf40f7 Mon Sep 17 00:00:00 2001
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Mon, 28 Jun 2021 11:58:47 +0200
-Subject: [PATCH] gnu: upower: Fix build directory.
-
-Remove explicit set of UPOWER_CONF_FILE_NAME in up-self-test.c;
-instead the harness should set it. In Guix we set it explicitly; the
-right thing is to use AM_TEST_ENVIRONMENT and regenerate the
-makefiles, but we can't regenerate because current autotools carp on
-some things, so we patch the Makefile.in instead.
-
-Also fix to not try to create /var/lib/upower if /var isn't writable.
-
-Based on a patch by Andy Wingo <wingo@igalia.com>
----
- src/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 3400139..f51ee89 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -181,7 +181,7 @@ $(systemdservice_DATA): $(systemdservice_in_files) Makefile
- endif
-
- install-data-hook:
-- if test -w $(DESTDIR)$(prefix)/; then \
-+ if test -w $(DESTDIR)$(localstatedir)/; then \
- mkdir -p $(DESTDIR)$(historydir); \
- fi
-
---
-2.32.0
-