aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:00 +0100
commita0a3ff72a22179f9b0532442450b5d5a4602143d (patch)
tree6000e68ef59e38a04cc6fcbd1fa2e7b53578f801
parent8937253fdeac838dd99072faa0cfad43ae286b4d (diff)
downloadguix-a0a3ff72a22179f9b0532442450b5d5a4602143d.tar
guix-a0a3ff72a22179f9b0532442450b5d5a4602143d.tar.gz
gnu: opendoas: Update to 6.8.2.
* gnu/packages/admin.scm (opendoas): Update to 6.8.2. [arguments]: Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/admin.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index e26458ae7e..5bb8840e94 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1802,7 +1802,7 @@ commands and their arguments.")
(define-public opendoas
(package
(name "opendoas")
- (version "6.8.1")
+ (version "6.8.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1811,7 +1811,7 @@ commands and their arguments.")
(file-name (git-file-name name version))
(sha256
(base32
- "0gfcssm21vdfg6kcrcc7hz1h4jmhy2zv29rfqyrrj3a6r9b5ah8p"))))
+ "1qrin7x9vcprk5pwjbr3w8z2qj8hk6xbvxicdhlk27xr6vcr1qzn"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1820,7 +1820,7 @@ commands and their arguments.")
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "GNUmakefile"
(("^\tchown.*$") ""))
- ;; OpenDoas look for binaries in safepath when a rule specify a
+ ;; OpenDoas looks for binaries in safepath when a rule specifies a
;; relative command, such as “permit keepenv :wheel cmd guix”.
(substitute* "doas.c"
(("safepath =" match)
@@ -1828,8 +1828,7 @@ commands and their arguments.")
"/run/setuid-programs:"
"/run/current-system/profile/bin:"
"/run/current-system/profile/sbin:"
- "\" ")))
- #t))
+ "\" ")))))
(replace 'configure
;; The configure script doesn't accept most of the default flags.
(lambda* (#:key configure-flags #:allow-other-keys)