aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-02-17 19:02:08 +0000
committerLudovic Courtès <ludo@gnu.org>2022-02-18 14:14:39 +0100
commit4262919ea9db4d5723e1233146b523333ab2728f (patch)
treef5e0773e3cb9fbc06afa342bda002e7887e2f9b3
parent569d7ba38c596ad092e5cd3b44922a6ba402da19 (diff)
downloadguix-4262919ea9db4d5723e1233146b523333ab2728f.tar
guix-4262919ea9db4d5723e1233146b523333ab2728f.tar.gz
gnu: umockdev: Reference libumockdev by absolute path.
* gnu/packages/check.scm (umockdev)[arguments]<#:phases>{absolute-introspection-library}: New phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/check.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 68a0ac7a84..058effab5c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2892,6 +2892,14 @@ provides a simple way to achieve this.")
(lambda _
(substitute* "tests/test-umockdev.c"
(("/run") "/tmp"))))
+ ;; Avoid having to set 'LD_LIBRARY_PATH' to use umockdev
+ ;; via introspection.
+ (add-after 'unpack 'absolute-introspection-library
+ (lambda _
+ (substitute* "Makefile.in"
+ (("g-ir-compiler -l libumockdev")
+ (string-append "g-ir-compiler -l " #$output
+ "/lib/libumockdev")))))
(add-after 'install 'absolute-filenames
(lambda* (#:key inputs #:allow-other-keys)
;; 'patch-shebangs' will take care of the shebang.