aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-12-31 12:25:49 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-26 10:19:35 +0100
commitf2205096430230ad185b1ee1dc01d46599904ae8 (patch)
tree9d06adb17c95dea18152190aa525ec352943b2fa
parent3455a004ec78a8c8a579b74da8039fbcd36cea73 (diff)
downloadguix-f2205096430230ad185b1ee1dc01d46599904ae8.tar
guix-f2205096430230ad185b1ee1dc01d46599904ae8.tar.gz
gnu: Switch default to GHC 9.2.
* gnu/packages/haskell.scm (ghc-9.0): Rename to just “ghc”. (ghc-9.2): Ditto. (ghc): Use ghc-9.2.
-rw-r--r--gnu/packages/haskell.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4eb13f76d7..3955e20f88 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1235,19 +1235,12 @@ interactive environment for the functional language Haskell.")
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory))))))
-;; Versions newer than ghc defined below (i.e. the compiler
-;; haskell-build-system uses) should use ghc-next as their name to
-;; ensure ghc (without version specification) and ghc-* packages are
-;; always compatible. See https://issues.guix.gnu.org/issue/47335.
-
(define-public ghc-8 ghc-8.10)
-(define-public ghc ghc-8)
-
(define-public ghc-9.0
(package
(inherit ghc-8.10)
- (name "ghc-next")
+ (name "ghc")
(version "9.0.2")
(source (origin
(method url-fetch)
@@ -1285,7 +1278,7 @@ interactive environment for the functional language Haskell.")
(let ((base ghc-8.10))
(package
(inherit base)
- (name "ghc-next")
+ (name "ghc")
(version "9.2.5")
(source (origin
(method url-fetch)
@@ -1327,6 +1320,12 @@ interactive environment for the functional language Haskell.")
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory)))))))
+;; Versions newer than ghc defined below (i.e. the compiler
+;; haskell-build-system uses) should use ghc-next as their name to
+;; ensure ghc (without version specification) and ghc-* packages are
+;; always compatible. See https://issues.guix.gnu.org/issue/47335.
+(define-public ghc ghc-9.2)
+
;; 9.4 is the last version to support the make-based build system,
;; but it boot with 9.2, only 9.0 is supported.
(define ghc-bootstrap-for-9.4 ghc-9.0)