aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-02-11 09:48:06 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-26 10:26:17 +0100
commit2c0537d3741447b02914beb8beab100e3464b181 (patch)
treead34ce3851c0511c639278d3a37af039f58faf58
parent6188fe26334bb023363e484ffb7729a366c6f1a2 (diff)
downloadguix-2c0537d3741447b02914beb8beab100e3464b181.tar
guix-2c0537d3741447b02914beb8beab100e3464b181.tar.gz
gnu: idris: Adapt to changed haskell-build-system.
…which does not support the “static” output any more. * gnu/packages/idris.scm (idris)[arguments]: Remove phase restore-libidris_rts.
-rw-r--r--gnu/packages/idris.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/idris.scm b/gnu/packages/idris.scm
index 2a5f63c174..85fb6cc2d2 100644
--- a/gnu/packages/idris.scm
+++ b/gnu/packages/idris.scm
@@ -122,17 +122,7 @@
(setenv "TASTY_NUM_THREADS" (number->string (parallel-job-count)))
(setenv "IDRIS_CC" ,(cc-for-target)) ;Needed for creating executables
(setenv "PATH" (string-append out "/bin:" (getenv "PATH")))
- (apply (assoc-ref %standard-phases 'check) args))))
- (add-before 'check 'restore-libidris_rts
- (lambda* (#:key outputs #:allow-other-keys)
- ;; The Haskell build system moves this library to the
- ;; "static" output. Idris only knows how to find it in the
- ;; "out" output, so we restore it here.
- (let ((out (assoc-ref outputs "out"))
- (static (assoc-ref outputs "static"))
- (filename "/lib/idris/rts/libidris_rts.a"))
- (rename-file (string-append static filename)
- (string-append out filename))))))))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
(native-search-paths
(list (search-path-specification
(variable "IDRIS_LIBRARY_PATH")