aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-10 14:48:51 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:50:20 +0100
commit009a22243e53c73cf8c90db3335d3a4393e36bdb (patch)
treecdfb3ddd15132704a3e63122aafe7148ec33a970
parentf99455766dc555145cd81240611dc3a0d13cefdc (diff)
downloadguix-009a22243e53c73cf8c90db3335d3a4393e36bdb.tar
guix-009a22243e53c73cf8c90db3335d3a4393e36bdb.tar.gz
gnu: Add rust-rust-embed-5.
* gnu/packages/crates-io.scm (rust-rust-embed-5): New variable.
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d4f5b31338..cef9eb8b43 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31514,6 +31514,38 @@ password hashing function.")
Currently the conversion uses the Bitcoin base58 alphabet.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-rust-embed-5
+ (package
+ (name "rust-rust-embed")
+ (version "5.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rust-embed" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "08smnqn21vn5zaywfki391v2l9v30cs0446qzzhvjssxmimgxq9g"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-actix-web" ,rust-actix-web-3)
+ ("rust-include-flate" ,rust-include-flate-0.1)
+ ("rust-mime-guess" ,rust-mime-guess-2)
+ ("rust-rocket" ,rust-rocket-0.4)
+ ("rust-rust-embed-impl" ,rust-rust-embed-impl-5)
+ ("rust-rust-embed-utils" ,rust-rust-embed-utils-5)
+ ("rust-tokio" ,rust-tokio-0.2)
+ ("rust-walkdir" ,rust-walkdir-2)
+ ("rust-warp" ,rust-warp-0.2))))
+ (home-page "https://github.com/pyros2097/rust-embed")
+ (synopsis "Rust custom @code{Derive} macro")
+ (description
+ "This package provides a custom @code{Derive} macro which loads files
+into the Rust binary at compile time during release and loads the file from
+the file-system during development.")
+ (license license:expat)))
+
(define-public rust-rust-embed-impl-5
(package
(name "rust-rust-embed-impl")