aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-10-16 22:23:50 +0200
committerBrian Leung <leungbk@mailfence.com>2019-10-16 22:23:50 +0200
commit65ecf3a7afcfcb96ec90dc0cabb6b2d1a1d54398 (patch)
tree776f6ec5b8fe97a53b47063f8000f68fed3794b5
parentabca6cf85a7b43897fa8705ccf93794c40404f87 (diff)
downloadguix-65ecf3a7afcfcb96ec90dc0cabb6b2d1a1d54398.tar
guix-65ecf3a7afcfcb96ec90dc0cabb6b2d1a1d54398.tar.gz
gnu: emacs-yasnippet: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-yasnippet)[source]: Use GIT-FETCH and GIT-FILE-NAME. [source]: Enable tests.
-rw-r--r--gnu/packages/emacs-xyz.scm31
1 files changed, 27 insertions, 4 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7287a4d8f9..d9bceac497 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8325,13 +8325,14 @@ been adapted to work with mu4e.")
(name "emacs-yasnippet")
(version "0.13.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/joaotavora/yasnippet/"
- "archive/" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/joaotavora/yasnippet.git")
+ (commit version)))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "12ls2x17agzbrj1xynjbmfa11igqxia4hj4fv6fpr66yci2r1plc"))
+ "0fkkplycrw8f8r30hjjxl1wm7p2irq2ipzzc1g7cc52abaal796p"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -8345,6 +8346,28 @@ been adapted to work with mu4e.")
"))\n"))
#t))))
(build-system emacs-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "--batch"
+ "-l" "yasnippet-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")
+ ;; FIXME: one failing test
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'make-tests-writable
+ (lambda _
+ (make-file-writable "yasnippet-tests.el")
+ #t))
+ (add-before 'check 'delete-rebinding-test
+ (lambda _
+ (emacs-batch-edit-file "yasnippet-tests.el"
+ `(progn (progn (goto-char (point-min))
+ (re-search-forward
+ "ert-deftest test-rebindings")
+ (beginning-of-line)
+ (kill-sexp))
+ (basic-save-buffer)))
+ #t)))))
(home-page "https://github.com/joaotavora/yasnippet")
(synopsis "Yet another snippet extension for Emacs")
(description