aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-10-17 12:02:44 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-17 12:02:44 +0200
commit0cfdc7506be2d879d2b76050a4f4188422682831 (patch)
tree04fde58d5e6190a2d38657110ba7d55884a744d6
parent7d66e87a5d297f24ebb3883a4f5bbea46fdfcdac (diff)
downloadguix-0cfdc7506be2d879d2b76050a4f4188422682831.tar
guix-0cfdc7506be2d879d2b76050a4f4188422682831.tar.gz
gnu: Add emacs-helm-sly.
* gnu/packages/emacs-xyz.scm (emacs-helm-sly): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 97fd4f91f9..4ced731edf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16346,6 +16346,36 @@ correctly.")
@end itemize\n")
(license license:gpl3+)))
+(define-public emacs-helm-sly
+ (package
+ (name "emacs-helm-sly")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-helm/helm-sly")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0agsigwnxm1czi7pzcfbjaks8kg63xskqqavvfqjwzj9xakh5id2"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)
+ ("emacs-sly" ,emacs-sly)))
+ (home-page "https://github.com/emacs-helm/helm-sly")
+ (synopsis "Helm for SLY, a Common Lisp interaction mode for Emacs")
+ (description "Helm-SLY defines a few new commands:
+
+@itemize
+@item helm-sly-list-connections: Yet another Lisp connection list with Helm.
+@item: helm-sly-apropos: Yet another @command{apropos} with Helm.
+@item helm-sly-mini: Like @command{helm-sly-list-connections}, but include an
+extra source of Lisp-related buffers, like the events buffer or the scratch
+buffer.
+@end itemize\n")
+ (license license:gpl3+)))
+
(define-public emacs-gtk-look
(package
(name "emacs-gtk-look")