aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-04-25 08:17:24 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 10:42:58 +0100
commita70c18a7c107ba0559143fe02b122ed2668cdd49 (patch)
tree527ea4342998893d010ba79f226e9a9feab4f27b
parent2676628ffba9ef9cacbb0a15e6fd730a73e51f1f (diff)
downloadguix-a70c18a7c107ba0559143fe02b122ed2668cdd49.tar
guix-a70c18a7c107ba0559143fe02b122ed2668cdd49.tar.gz
gnu: cgit: Fix included scripts.
Fix the about-formatting.sh, syntax-highlighting.py and html-converters files. * gnu/packages/version-control.scm (cgit)[arguments]: Include about-formatting.sh and the html-converters in the patch-absolute-file-names phase and add a wrap-python-scripts phase to wrap syntax-highlighting.py and the md2html converter. [inputs]: Add groff, python, python-docutils, python-markdown and python-pygments.
-rw-r--r--gnu/packages/version-control.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index b41529d4f8..f53d0f4fa9 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
+;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -551,6 +552,21 @@ collaboration using typical untrusted file hosts or services.")
(quoted-file-name (assoc-ref inputs "bzip2") "/bin/bzip2"))
(("\"xz\"")
(quoted-file-name (assoc-ref inputs "xz") "/bin/xz")))
+
+ (substitute* "filters/about-formatting.sh"
+ (("$\\(dirname $0\\)") (string-append (assoc-ref outputs "out")
+ "/lib/cgit/filters"))
+ (("\\| tr") (string-append "| " (which "tr"))))
+
+ (substitute* "filters/html-converters/txt2html"
+ (("sed") (which "sed")))
+
+ (substitute* "filters/html-converters/man2html"
+ (("groff") (which "groff")))
+
+ (substitute* "filters/html-converters/rst2html"
+ (("rst2html\\.py") (which "rst2html.py")))
+
#t))
(delete 'configure) ; no configure script
(add-after 'build 'build-man
@@ -569,7 +585,17 @@ collaboration using typical untrusted file hosts or services.")
;; to get it stripped.
(rename-file (string-append out "/share/cgit/cgit.cgi")
(string-append out "/lib/cgit/cgit.cgi"))
- #t)))))))
+ #t))))
+ (add-after 'install 'wrap-python-scripts
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each
+ (lambda (file)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/lib/cgit/filters/" file)
+ `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))))
+ '("syntax-highlighting.py"
+ "html-converters/md2html"))
+ #t)))))
(native-inputs
;; For building manpage.
`(("asciidoc" ,asciidoc)
@@ -588,6 +614,11 @@ collaboration using typical untrusted file hosts or services.")
(base32
"1r2aa19gnrvm2y4fqcvpw1g9l72n48axqmpgv18s6d0y2p72vhzj"))))
("openssl" ,openssl)
+ ("groff" ,groff)
+ ("python" ,python)
+ ("python-docutils" ,python-docutils)
+ ("python-markdown" ,python-markdown)
+ ("python-pygments" ,python-pygments)
("zlib" ,zlib)))
(home-page "https://git.zx2c4.com/cgit/")
(synopsis "Web frontend for git repositories")