aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2018-05-13 01:40:30 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-14 23:01:36 +0200
commit5834e4b70aef727d591c271ce3141ed23753377e (patch)
treeb29e053950617eada581fb8c38ed3a19a9d67f2a
parent5ac7bf56d0b20d505b747425c5d17f2cc33d9302 (diff)
downloadguix-5834e4b70aef727d591c271ce3141ed23753377e.tar
guix-5834e4b70aef727d591c271ce3141ed23753377e.tar.gz
gnu: opencv: Ignore CVEs.
* gnu/packages/image-processing.scm (opencv)[properties]: Add a lint-hidden-cve property and add three CVEs to be ignored. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/image-processing.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index ef303e1349..c69629e4a9 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -372,6 +372,11 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
("protobuf" ,protobuf)
("vtk" ,vtk)
("python" ,python)))
+ ;; These three CVEs are not a problem of OpenCV, see:
+ ;; https://github.com/opencv/opencv/issues/10998
+ (properties '((lint-hidden-cve . ("CVE-2018-7712"
+ "CVE-2018-7713"
+ "CVE-2018-7714"))))
(synopsis "Computer vision library")
(description "OpenCV is a library aimed at
real-time computer vision, including several hundred computer