aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-05-17 23:07:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-17 23:08:30 +0200
commit4ca958111908eda0452c47c8cb467a1bd0c9bc87 (patch)
treec2e479ed82056e8cee133b69c2d31f040b05e9dd
parent162825f9653f1ba050e40f0ca96d1eb3491a9207 (diff)
downloadguix-4ca958111908eda0452c47c8cb467a1bd0c9bc87.tar
guix-4ca958111908eda0452c47c8cb467a1bd0c9bc87.tar.gz
gnu: multiqc: Fix build.
* gnu/packages/bioinformatics.scm (multiqc)[arguments]: Add a ‘relax-requirements’ phase to fix building with python-matplotlib@2.2.
-rw-r--r--gnu/packages/bioinformatics.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7a121557db..8bfe01fd6f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9085,6 +9085,19 @@ replacement for strverscmp.")
("python-numpy" ,python-numpy)
;; MultQC checks for the presence of nose at runtime.
("python-nose" ,python-nose)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ ;; MultiQC 1.5 ‘requires’ a version of python-matplotlib older
+ ;; than the one in Guix, but should work fine with 2.2.2.
+ ;; See <https://github.com/ewels/MultiQC/issues/725> and
+ ;; <https://github.com/ewels/MultiQC/issues/732> for details.
+ (("['\"]matplotlib.*?['\"]")
+ "'matplotlib'"))
+ #t)))))
(home-page "http://multiqc.info")
(synopsis "Aggregate bioinformatics analysis reports")
(description