aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-01-08 14:58:06 +0000
committerChristopher Baines <mail@cbaines.net>2020-03-26 19:08:58 +0000
commit77b60dad0dadc726729ced24a944af9613917a38 (patch)
tree681e740fbd012c52f8c9fe62500ca358f2f6e8b4
parent8bfe5a9f74ad1df7661462773f571fbb12e9edb3 (diff)
downloadguix-77b60dad0dadc726729ced24a944af9613917a38.tar
guix-77b60dad0dadc726729ced24a944af9613917a38.tar.gz
gnu: Add python-requests_ntlm.
* gnu/packages/python-web.scm (python-requests_ntlm): New variable.
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b02ffd5f58..6f6b5fd4d3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
+;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1422,6 +1423,30 @@ than Python’s urllib2 library.")
(define-public python2-requests
(package-with-python2 python-requests))
+(define-public python-requests_ntlm
+ (package
+ (name "python-requests_ntlm")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests_ntlm" version))
+ (sha256
+ (base32
+ "0wgbqzaq9w7bas16b7brdb75f91bh3275fb459093bk1ihpck2ci"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)
+ ("python-ntlm-auth" ,python-ntlm-auth)
+ ("python-requests" ,python-requests)))
+ (home-page "https://github.com/requests/requests-ntlm")
+ (synopsis
+ "NTLM authentication support for Requests")
+ (description
+ "This package allows for HTTP NTLM authentication using the requests
+library.")
+ (license license:isc)))
+
(define-public python-requests-mock
(package
(name "python-requests-mock")