aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-21 22:57:48 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-21 22:57:48 +0100
commit6bc00737b067617481ca207fc8e6aaa6fe441b3a (patch)
treef50baf10f718411896b3b7eca0ec8284854554f2
parentafd90f8d62de252931be9c1fa3a5c6e3b1074b04 (diff)
downloadguix-6bc00737b067617481ca207fc8e6aaa6fe441b3a.tar
guix-6bc00737b067617481ca207fc8e6aaa6fe441b3a.tar.gz
gnu: vte-ng: Fetch source using git.
* gnu/packages/gnome.scm (vte-ng)[source]: Rewrite in terms of GIT-FETCH.
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1420a55f24..692e3dedef 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2117,6 +2117,13 @@ editors, IDEs, etc.")
(name "vte-ng")
(version "0.52.2.a")
(home-page "https://github.com/thestinger/vte-ng")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1csmjrw3c2avh711xcrn3khqwp4cwz97c3fmyirq2rg0hndng4s3"))))
(native-inputs
`(("gtk-doc" ,gtk-doc)
("gperf" ,gperf)
@@ -2124,14 +2131,6 @@ editors, IDEs, etc.")
("automake" ,automake)
("libtool" ,libtool)
,@(package-native-inputs vte)))
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/thestinger/"
- name "/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1fd65mk7c87k03vhnb2ixkjvv9nja04mfq813iyjji1b11f2sh7v"))))
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'bootstrap