aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-19 00:08:59 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-20 22:46:59 -0500
commitf8b6d18171211aee0a471bb5df6c05f5163fe5e6 (patch)
tree7dfb4997a985fd0409fe54b4c0358c03c01f5b9f
parent66cb42106d8eda6144ed378bb81c95c31bcce92b (diff)
downloadguix-f8b6d18171211aee0a471bb5df6c05f5163fe5e6.tar
guix-f8b6d18171211aee0a471bb5df6c05f5163fe5e6.tar.gz
gnu: Add python-dpkt.
* gnu/packages/python-web.scm (python-dpkt): New variable.
-rw-r--r--gnu/packages/python-web.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d4f59be83f..96262211cf 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3016,6 +3016,24 @@ library.")
@code{Requests} with @code{Gevent} to make asynchronous HTTP Requests easily")
(license license:bsd-2)))
+(define-public python-dpkt
+ (package
+ (name "python-dpkt")
+ (version "1.9.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dpkt" version))
+ (sha256
+ (base32
+ "1d28r8pmhzjjd6hrn1xcddinfhwv8lcl1s59ygmqa8kfmz5pkrgl"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/kbandla/dpkt")
+ (synopsis "Packet generator and parser for TCP/IP protocols")
+ (description "The dpkt module is a fast, simple packet generator and parser
+for the basic TCP/IP protocols.")
+ (license license:bsd-3)))
+
(define-public python-geventhttpclient
(package
(name "python-geventhttpclient")