aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2020-12-22 12:25:50 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2020-12-22 12:25:50 +0100
commitd7d5bca4f8968932cbe8b9bf584e68c76a549d39 (patch)
tree3d7beef9bcf58dc41973b104f4407897803091bc
parent2e7c2dc8fa64442eb5b67670c5533090bebdd7fd (diff)
downloadguix-d7d5bca4f8968932cbe8b9bf584e68c76a549d39.tar
guix-d7d5bca4f8968932cbe8b9bf584e68c76a549d39.tar.gz
gnu: Add spdlog@1.7.
Required by waybar. * gnu/packages/logging.scm (spdlog-1.7): New variable.
-rw-r--r--gnu/packages/logging.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 39217e1869..87283f3752 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -215,3 +215,19 @@ library.")
;; spdlog is under Expat license, but the bundled fmt library in
;; "include/spdlog/fmt/bundled" is under BSD 2 clause license.
(license (list license:expat license:bsd-2))))
+
+(define-public spdlog-1.7
+ (package
+ (inherit spdlog)
+ (name "spdlog")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gabime/spdlog")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ryaa22ppj60461hcdb8nk7jwj84arp4iw4lyw594py92g4vnx3j"))))))