aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-12-20 13:19:04 +0000
committerLudovic Courtès <ludo@gnu.org>2020-12-22 16:32:29 +0100
commitb9ab9fee74311c8f56a5147b6dea789075b1fa82 (patch)
tree23c4e359597b5f215e9ee44a217a52a93971d2f9
parent20cf7f75ff1a944726e8a4a264d7a087f039840e (diff)
downloadguix-b9ab9fee74311c8f56a5147b6dea789075b1fa82.tar
guix-b9ab9fee74311c8f56a5147b6dea789075b1fa82.tar.gz
gnu: intel-mpi-benchmarks: Update to 2019.6.
* gnu/packages/benchmarks.scm (intel-mpi-benchmarks): Update to 2019.6. [source]: Add 'snippet'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/benchmark.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index ad9262d3a1..3470f3860b 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -131,7 +132,7 @@ is to write a job file matching the I/O load one wants to simulate.")
(if (string=? (package-name mpi) "openmpi")
""
(string-append "-" (package-name mpi)))))
- (version "2019.3")
+ (version "2019.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -140,7 +141,16 @@ is to write a job file matching the I/O load one wants to simulate.")
(file-name (git-file-name name version))
(sha256
(base32
- "0si5xi6ilhd3w0gbsg124589pvp094hvf366rvjjb9pi7pdk5p4i"))))
+ "02hxbk9g9nl59bk5qcfl3djj7b58vsqys340m1xdbyqwcrbnahh9"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Some source configuration files in the original tarball
+ ;; have inappropriate execute permissions, which interferes
+ ;; with the install phase below.
+ (for-each (lambda (file) (chmod file #o444))
+ (find-files "WINDOWS" "."))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("mpi" ,mpi)))