aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-22 14:05:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-22 14:18:34 +0100
commit9e36859c9b80a00c3ee5138771eba93edc16a11c (patch)
tree2aecf97245e4d44b03591378b1a515271ec1f8d3
parent5f5e3873d735d13824c172d779e6095d6947f340 (diff)
downloadguix-9e36859c9b80a00c3ee5138771eba93edc16a11c.tar
guix-9e36859c9b80a00c3ee5138771eba93edc16a11c.tar.gz
gnu: Add pamtester.
* gnu/packages/authentication.scm (pamtester): New variable.
-rw-r--r--gnu/packages/authentication.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/authentication.scm b/gnu/packages/authentication.scm
index afa20945e7..e45bbb6b26 100644
--- a/gnu/packages/authentication.scm
+++ b/gnu/packages/authentication.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -115,3 +115,28 @@ and the time-based @dfn{TOTP} algorithm (RFC6238).")
(description "The Yubico PAM module provides an easy way to integrate the
YubiKey into your existing user authentication infrastructure.")
(license license:bsd-2))))
+
+(define-public pamtester
+ (package
+ (name "pamtester")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/pamtester/pamtester/"
+ version "/pamtester-" version ".tar.gz"))
+ (sha256
+ (base32 "1mdj1wj0adcnx354fs17928yn2xfr1hj5mfraq282dagi873sqw3"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("linux-pam" ,linux-pam)))
+ (home-page "http://pamtester.sourceforge.net/")
+ (synopsis "Utility for testing pluggable authentication modules (PAM) facility")
+ (description
+ "Pamtester is a tiny utility program to test the pluggable authentication
+modules (PAM) facility, specifically designed to help PAM module authors to
+intensively test their own modules.")
+ (license license:bsd-3)))