aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAniket Patil <aniket112.patil@gmail.com>2020-12-22 23:20:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-22 23:29:22 +0100
commit4d1459dc035ab6a77cdfbbc503f3ea9eb2977f97 (patch)
tree63c408e963e786d18a3e99586b572e71bb8fe699
parent3581d4be95980b375884cca79d7f8896891caace (diff)
downloadguix-4d1459dc035ab6a77cdfbbc503f3ea9eb2977f97.tar
guix-4d1459dc035ab6a77cdfbbc503f3ea9eb2977f97.tar.gz
gnu: Add r-metafor.
* gnu/packages/cran.scm (r-metafor): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9c6ee08f58..7eec3c9bd7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24876,6 +24876,43 @@ censored data with competing risks (see data set @code{menopause}). The
package also provides functions to visualize the observed data and the MLE.")
(license license:gpl2+)))
+(define-public r-metafor
+ (package
+ (name "r-metafor")
+ (version "2.4-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "metafor" version))
+ (sha256
+ (base32
+ "1b599fxk7s0brkchmx698fr5k4g1kzkia2rnlvhg349ffs5nfjmn"))))
+ (properties `((upstream-name . "metafor")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrix" ,r-matrix)
+ ("r-nlme" ,r-nlme)))
+ (home-page "https://cran.r-project.org/web/packages/metafor/")
+ (synopsis "Meta-analysis package for R")
+ (description
+ "This package provides a comprehensive collection of functions for
+conducting meta-analyses in R. The package includes functions to calculate
+various effect sizes or outcome measures, fit fixed-, random-, and
+mixed-effects models to such data, carry out moderator and meta-regression
+analyses, and create various types of meta-analytical plots (e.g., forest,
+funnel, radial, L'Abbe, Baujat, GOSH plots). For meta-analyses of binomial
+and person-time data, the package also provides functions that implement
+specialized methods, including the Mantel-Haenszel method, Peto's method, and
+a variety of suitable generalized linear (mixed-effects) models (i.e.
+mixed-effects logistic and Poisson regression models). Finally, the package
+provides functionality for fitting meta-analytic multivariate/multilevel
+models that account for non-independent sampling errors and/or true
+effects (e.g. due to the inclusion of multiple treatment studies, multiple
+endpoints, or other forms of clustering). Network meta-analyses and
+meta-analyses accounting for known correlation structures (e.g. due to
+phylogenetic relatedness) can also be conducted.")
+ (license license:gpl2+)))
+
(define-public r-perm
(package
(name "r-perm")