aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-12-20 15:10:58 -0600
committerBrett Gilio <brettg@gnu.org>2020-12-20 15:10:58 -0600
commit0717ab7615b1e4201bf4e4a2997213ed7bb65f4b (patch)
tree1f516f38f17e8b368fd5e9a88b16fe74fdd2fa1e
parentb6d96be80c6bc8b11eccbd68ff0824ccaf03f4e5 (diff)
downloadguix-0717ab7615b1e4201bf4e4a2997213ed7bb65f4b.tar
guix-0717ab7615b1e4201bf4e4a2997213ed7bb65f4b.tar.gz
gnu: straw-viewer: Move youtube-dl to propagated inputs.
* gnu/packages/video.scm (straw-viewer)[propagated-inputs]: Add youtube-dl.
-rw-r--r--gnu/packages/video.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bde45734f3..9d69973182 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1032,13 +1032,13 @@ H.264 (MPEG-4 AVC) video streams.")
("perl-mozilla-ca" ,perl-mozilla-ca)
("perl-term-readline-gnu" ,perl-term-readline-gnu)
("perl-unicode-linebreak" ,perl-unicode-linebreak)
- ("xdg-utils" ,xdg-utils)
-
- ;; Some videos play without youtube-dl, but others silently fail to.
- ("youtube-dl" ,youtube-dl)))
-
- ;; Required only when building the graphical interface (--gtk).
- ;;("perl-file-sharedir" ,perl-file-sharedir)
+ ("xdg-utils" ,xdg-utils)))
+ ;; Required only when building the graphical interface (--gtk).
+ ;;("perl-file-sharedir" ,perl-file-sharedir)
+
+ ;; Some videos play without youtube-dl, but others silently fail to.
+ (propagated-inputs
+ `(("youtube-dl" ,youtube-dl)))
(arguments
`(#:modules ((guix build perl-build-system)
(guix build utils)