aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-12-22 18:01:58 +0100
committerLeo Famulari <leo@famulari.name>2020-12-22 14:10:08 -0500
commit06de9ca75f4bb508cdba3082d8ae80f014dbc38b (patch)
tree35633fb8e1e9d104633d2db751f9293830e4dcd3
parentaa6d4371d5f8413fe471ae820475b47adb869b28 (diff)
downloadguix-06de9ca75f4bb508cdba3082d8ae80f014dbc38b.tar
guix-06de9ca75f4bb508cdba3082d8ae80f014dbc38b.tar.gz
gnu: perl-geo-ip: Remove package.
Fixes <https://bugs.gnu.org/29485>. * gnu/packages/networking.scm (perl-geo-ip): Remove variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/networking.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index d3f47da163..ff1de3a0cb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2066,30 +2066,6 @@ It is intended primarily for use in testing.")
(description "Net::CIDR::Lite merges IPv4 or IPv6 CIDR addresses.")
(license license:gpl1+)))
-;; TODO: Use the geolite-mirror-simple.pl script from the example
-;; directory to stay current with the databases. How?
-(define-public perl-geo-ip
- (package
- (name "perl-geo-ip")
- (version "1.51")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://cpan/authors/id/M/MA/MAXMIND/Geo-IP-"
- version
- ".tar.gz"))
- (sha256
- (base32
- "1fka8fr7fw6sh3xa9glhs1zjg3s2gfkhi7n7da1l2m2wblqj0c0n"))))
- (build-system perl-build-system)
- (home-page "https://metacpan.org/release/Geo-IP")
- (synopsis
- "Look up location and network information by IP Address in Perl")
- (description "The Perl module @code{Geo::IP}. It looks up location and
-network information by IP Address.")
- (license license:perl-license)))
-
(define-public perl-io-socket-inet6
(package
(name "perl-io-socket-inet6")